摘自:https://www.cnblogs.com/beginner-boy/p/8580659.html

问题描述:

之前PC上安装的是Python2,后来工作需要转成Python3了。然后在用pycharm运行Python2的程序时发现源程序运行报错(出去语法错误)

error:please select a valid Python interpreter

问题原因:

在pycharm导入源项目的时候没有选择运行Python的程序

解决办法:

1、更改Pycharm的设置 ,打开settings(CTRL + ALT + S)或者file>settings,打开配置框,

2、在查询框中输入interpreter,进行查询

操作步骤如下:

  • 第一步:输出要查询的内容
  • 第二步:选择Project Interpreter
  • 第三步:选择界面右边上的配置按钮,右击选择add local
  • 第四步:选择system interpreter,然后选择安装的Python路径即可
最后修改日期:2020年2月8日